12/20/12: Bioinformatics Software Updates - Important information

 

Important Information for Command-line Users of MSI Bioinformatics Software

On January 14, 2013 several bioinformatics software packages installed at MSI will be upgraded to new versions that are not backward compatible with previous releases. This may potentially affect user workflows, scripts, or pipelines that were operational prior to the upgrade.  Scheduled software packages are listed below.

Please note that these upgrades only impact software used in command-line mode.  Tools and workflows in Galaxy will not be affected. 

 

These new versions are to become the default loaded version when using the "module load" function at MSI when no version is specified. Please note that the previous version will still be available to the user. You can use the "module load" command to specify which version of the software you want to use. To identify which software versions are available, type "module avail" on the system of interest.

 

Please contact help@msi.umn.edu if you have questions or problems with this change. Please include "RISS" in the subject line of your message.

 

Details:

Software package: Bowtie

Current default version loaded by "module load bowtie": 0.12.8

New version loaded by "module load bowtie" after upgrade: 2.0.5

To continue using the old version use: module load bowtie/0.12.8

Compatibility issues: Bowtie genome indexes built using 0.X versions are not compatible with indexes built using 2.X versions. Bowtie 2.X genome indexes are available at /project/db/genomes/[SPECIES]/[BUILD]/bowtie2/  (i.e.

/project/db/genomes/Hsapiens/hg19/bowtie2). Significant changes

(improvements) have been made to Bowtie command-line options, and to how Bowtie performs alignments. The Bowtie programs have been renamed from "bowtie" to "bowtie2".

Find more information

 

Software package: Tophat

Current default version loaded by "module load tophat": 1.4.1

New version loaded by "module load tophat" after upgrade: 2.0.5

To continue loading the old version use: module load tophat/1.4.1

Compatibility issue: The new version of Tophat uses Bowtie 2.X instead of Bowtie 0.X, and therefore uses Bowtie 2.X genome indexes.

Significant changes (improvements) have been made to Tophat command-line options, and to how Tophat performs alignments.

Find more information.

 

Software package: Cufflinks

Current default version loaded by "module load cufflinks": 1.3.0

New version loaded by "module load cufflinks" after upgrade: 2.0.2

To continue using the old version use: module load cufflinks/1.3.0

Compatibility issue: Significant changes (improvements) have been made to Cufflinks command-line options, and to how Cufflinks calculates differential expression. Output file formats have been changed.

Find more information

 

Software package: GATK

Current default version loaded by "module load gatk": 1.6

New version loaded by "module load gatk" after upgrade: 2.3

To continue using the old version use: module load gatk/1.6

Compatibility issues: The GATK 2.X releases include both the addition of brand-new (and often still experimental) tools and updates to the existing stable tools. These updates will require users to change how they are using GATK tools. GATK 2.X is released under a different license that places restrictions on commercial usage.

Find more information